APP : Maintenance extension till 4:30 AM PST

Incident Report for Palo Alto Networks Cloud Services

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 10:54 UTC

Investigating

We are currently investigating this issue.
Posted Mar 11, 2026 - 09:02 UTC