Prisma Access: Maintenance Upgrade Required March 28th 2025

Incident Report for Palo Alto Networks Cloud Services

Update

We are continuing to investigate this issue.
Posted Mar 26, 2025 - 21:03 UTC

Investigating

At Palo Alto Networks, we are committed to providing best-in-class security and operational excellence. As part of our proactive approach, we will be upgrading your Prisma Access instances to a version that includes a wide range of stability and security enhancements. These enhancements are designed to strengthen our services to safeguard your data and network integrity.
We need to schedule a maintenance window for your tenant to facilitate this upgrade. We intend to execute this upgrade over the weekend of March 28th, 2025.
Thank you for your understanding and cooperation during this time. If you have any further questions or require assistance, please feel free to reach out to your Palo Alto Networks account team, the customer success team, or the support team.
Posted Mar 26, 2025 - 21:01 UTC