Scheduled Maintenance Status Notification
Incident Report for Palo Alto Networks Cloud Services
Resolved
Maintenance activity is now completed.
Posted Apr 13, 2024 - 06:54 UTC
Investigating
Status Update: Maintenance in Progress
We are currently implementing a regular maintenance activity to enhance our services, which is a scheduled maintenance window on Saturday, April 13th, from 4:00 AM UTC to 8:00 AM UTC. Additionally, please note that RBI service may face some performance degradation while this regular maintenance activity is underway. We appreciate your understanding and cooperation. Stay informed with real-time updates at sase.status.paloaltonetworks.com. No other services will be impacted during this maintenance
Posted Apr 13, 2024 - 04:52 UTC