Azure West US 3, West Europe & Central US Network issues  impacting Cloud NGFW Services

Incident Report for Palo Alto Networks Cloud Services

Resolved

Azure notified services has been restored.
Posted Mar 11, 2026 - 09:38 UTC

Monitoring

Azure has mitigated the underlying intermittent network issue. We are monitoring for continued stability.
Posted Mar 11, 2026 - 08:17 UTC

Update

We are continuing to investigate this issue.
Posted Mar 11, 2026 - 05:49 UTC

Investigating

Azure West US 3, West Europe & Central US regions experiencing Intermittent Network connectivity issue which may be impacting CNGFW Services.


Ongoing Actions: Our engineering team is working closely with the Azure team. Azure status updates can be tracked through the Service Page.

West US 3 https://app.azure.com/h/TGDZ-X10/0858a9
Central US https://app.azure.com/h/PG9P-X40/4cd327
West Europe https://app.azure.com/h/8ZSP-XL0/35bdc8
Posted Mar 11, 2026 - 05:11 UTC
This incident affected: Cloud NGFW for Azure (centralus, westeurope, westus3).