[ Extended ] Prisma Cloud [APP2.EU]: 26.2.1 Scheduled Release Maintenance

Incident Report for Palo Alto Networks Cloud Services

Resolved

We completed the maintenance successfully.
Posted Feb 20, 2026 - 07:01 UTC

Monitoring

Maintenance Update 26.2.1 ( app2.eu )

We are extending the ongoing PC release window for app2.eu by an additional 90 minutes.
We are in the final stages of application validation and are working to complete the maintenance as quickly as possible. We appreciate your patience and understanding.
Posted Feb 20, 2026 - 05:11 UTC
This incident affected: Prisma Cloud (Europe - app2.eu.prismacloud.io).