Customer Service Portal is having intermittent connectivity issues

Incident Report for Palo Alto Networks Cloud Services

Resolved

Incident is resolved
Posted Mar 10, 2026 - 18:22 UTC

Monitoring

The problem has been mitigated , we will continue monitoring this incident
Posted Mar 10, 2026 - 17:52 UTC

Investigating

Intermittent connectivity issues were first observed at 9:41 AM PDT. We are actively investigating the issue.
Posted Mar 10, 2026 - 17:30 UTC
This incident affected: Customer Support Portal.