AWS Middle East(Bahrain) outage impacting Cloud NGFW Services.

Incident Report for Palo Alto Networks Cloud Services

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 21:49 UTC

Identified

AWS Middle East(Bahrain) outage impacting Cloud NGFW Services.
We are aware of power outage in AWS Bahrain region. We are evaluating the impact on Cloud NGFW services in this region. Customers may experience failures to deploy new resources in this region.
Ongoing Actions: Our engineering team is monitoring the provider’s recovery efforts and is prepared to validate service health as soon as infrastructure stabilizes. You can also monitor the underlying platform status via the AWS Status Page: https://health.aws.amazon.com/health/status?path=service-history
Next Update: 9:00PM 3/02/2026 UTC.
Posted Mar 02, 2026 - 16:51 UTC
This incident affected: Cloud NGFW for AWS (Bahrain(me-south-1)).