Prisma Access Browser - Service Degradation

Incident Report for Palo Alto Networks Cloud Services

Resolved

The services are in recovery, and we are continuing to monitor.
Posted Mar 26, 2025 - 10:42 UTC

Monitoring

We identified an issue causing services degradation in Prisma Access Browser services, we are working to resolve it.
We issued a fix and we are monitoring the services.
Posted Mar 26, 2025 - 08:43 UTC