AWS EU-NORTH-1 (Stockholm) disruption impacting Cloud NGFW

Incident Report for Palo Alto Networks Cloud Services

Resolved

The issue has been resolved and all services are operating normally.
Posted Jun 30, 2026 - 22:04 UTC

Identified

We are aware of an ongoing AWS operational issue in the EU-NORTH-1 (Stockholm)
region affecting EC2 APIs and Elastic Load Balancing. This is impacting
provisioning and management operations for Cloud NGFW resources in EU-NORTH-1.

Existing Cloud NGFW instances and traffic processing are not affected — the
impact is limited to new instance launches and API-driven operations in this
region.

We are monitoring AWS's progress and will update as we learn more.
Posted Jun 30, 2026 - 21:30 UTC
This incident affected: Cloud NGFW for AWS (Stockholm (eu-north-1)).