Recommendations for Addressing Site Access Challenges with Decryption on Google Chrome Browser 124 and Higher
Incident Report for Palo Alto Networks Cloud Services
Update
We are continuing to monitor for any further issues.
Posted Apr 25, 2024 - 01:50 UTC
Monitoring
For customers encountering challenges while accessing specific sites with decryption enabled and upon receiving "decrypt-unsupport-param" logs, particularly when using Google Chrome browser version 124 and higher, we suggest trying the following steps:

Issue Identification: The observed difficulties may arise from Kyber Support integrated by Chrome for the TLS 1.3 version.

Chrome Flags Configuration: Please review the configuration settings in Chrome Flags. This can be done by navigating to "chrome://flags/#enable-tls13-kyber" and examining the setup.

Disabling the Option: We encourage you to consider disabling the Kyber Support option and then relaunching the browser to assess if it resolves the issue.


If you continue to experience any difficulties, please open a support case, sincerely appreciate your patience as we diligently work to resolve this matter.
Posted Apr 25, 2024 - 01:48 UTC