We will be undergoing scheduled maintenance during this time.
Posted May 13, 2026 - 17:32 UTC
Scheduled
IAM Service Upgrade — Saturday, May 16
We are upgrading the IAM Service to a new architecture to improve reliability and scalability.
What to Expect: Available: Login and all non-IAM operations. Unavailable: IAM write operations — including creating or updating access policies and Tenant Service Group (TSG) creation/updates. Read-only IAM access is unaffected. Only administrative changes to policies and TSGs will be blocked during the window.
Recommended Action: Please complete any pending IAM policy or TSG changes before the maintenance window begins. Normal access will resume automatically once the upgrade is complete.
Thank you for your patience.
Posted May 13, 2026 - 17:00 UTC
This scheduled maintenance affects: Strata Cloud Manager (Cloud Manager North America (United States), Cloud Manager North America (Canada), Cloud Manager Europe (United Kingdom), Cloud Manager APAC (Japan), Cloud Manager APAC (India), Cloud Manager APAC (Singapore), Cloud Manager Europe (Switzerland), Cloud Manager Europe (Germany), Cloud Manager APAC (Australia), Cloud Manager Middle East (Qatar), Cloud Manager Europe (France), Cloud Manager APAC (Indonesia), Cloud Manager Middle East (Israel), Cloud Manager Middle East (Saudi Arabia), Cloud Manager Africa (South Africa), Cloud Manager North America (FedRamp Moderate), Cloud Manager North America (FedRamp High)) and Hub.