Increased latency observed on Customer Support Portal

Incident Report for Palo Alto Networks Cloud Services

Resolved

The underlying problem causing increased latency on the Customer Service Portal has been resolved at 12:34 AM UTC.
All services are operational.
Posted Jun 05, 2025 - 00:38 UTC

Investigating

Increased latency observed on Customer Support Portal, some functionalities are degraded. Investigation in progress. Next update ETA : 12:58 AM UTC
Posted Jun 05, 2025 - 00:09 UTC
This incident affected: Customer Support Portal.