[Azure] [EastUS] outage impacting Cloud NGFW Services

Incident Report for Palo Alto Networks Cloud Services

Resolved

The Azure East US infrastructure issue has been resolved by Microsoft. Cloud NGFW for Azure - eastus is fully operational. No active Azure CSP provider incidents remain. Customers should no longer experience failures when provisioning, scaling, or updating resources.
Posted Apr 25, 2026 - 01:21 UTC

Update

We have identified an issue with Azure affecting the Cloud NGFW EastUS region. Customers may experience failures to deploy new resources

Current Status: Azure is still experiencing failures or delays when provisioning, scaling, or updating Azure resources. This is impacting our ability to Provision New firewalls and perform autoscale actions

Ongoing Actions: Our engineering team is monitoring the provider’s recovery efforts and is prepared to validate service health as soon as infrastructure stabilizes. You can also monitor the underlying platform status via the Azure Status Page:

https://azure.status.microsoft/en-us/status

Next Update: in 4 hours 03:04:54 UTC UTC 4/25/26
Posted Apr 24, 2026 - 23:05 UTC

Investigating

We have identified an issue with Azure affecting the Cloud NGFW EastUS region. Customers may experience failures to deploy new resources

Current Status: Azure is currently experiencing failures or delays when provisioning, scaling, or updating Azure resources. This is impacting our ability to Provision New firewalls and perform autoscale actions

Ongoing Actions: Our engineering team is monitoring the provider’s recovery efforts and is prepared to validate service health as soon as infrastructure stabilizes. You can also monitor the underlying platform status via the Azure Status Page: https://azure.status.microsoft/en-us/status

Next Update: in 4 hours 22:54:00 UTC 4/24/26
Posted Apr 24, 2026 - 18:54 UTC
This incident affected: Cloud NGFW for Azure (eastus).