AWS EU-WEST-3 outage impacting Cloud NGFW Services.

Incident Report for Palo Alto Networks Cloud Services

Resolved

AWS has closed the issues and Cloud NGFW services are no longer impacted
Posted Apr 27, 2026 - 20:59 UTC

Monitoring

AWS has resolved the Lambda, EC2 Availability & Dynamo DB errors. We are monitoring for continued stability.
Posted Apr 27, 2026 - 12:30 UTC

Investigating

We have identified an issue with AWS affecting the Cloud NGFW EU-WEST-3 region.
Customers may experience failures to deploy new resources or delays in rule synchronization
Current Status: AWS is currently experiencing DynamoDB API error rate & EC2 Availability Issue
Ongoing Actions: Our engineering team is monitoring the provider’s recovery efforts and is prepared to validate service health as soon as infrastructure stabilizes. You can also monitor the underlying platform status via the AWS Health Dashboard
Next Update: 1 PM UTC 27th Apr 2026
Posted Apr 27, 2026 - 11:50 UTC
This incident affected: Cloud NGFW for AWS (Paris (eu-west-3)).