Provisioning new tenants current degraded

Incident Report for Palo Alto Networks Cloud Services

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 17:23 UTC

Investigating

We are currently investigating the issue
Posted Nov 26, 2025 - 07:21 UTC
This incident affected: Strata Logging Service (United States - Americas, Netherlands - Europe, United States - Government, Canada).